Bug 651 - unbound 1.5.2 crashes with HUP
unbound 1.5.2 crashes with HUP
Status: RESOLVED DUPLICATE of bug 647
Product: unbound
Classification: Unclassified
Component: server
1.5.2
x86_64 Linux
: P5 major
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-08 11:04 CET by Paul Bredbury
Modified: 2015-03-09 09:07 CET (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Bredbury 2015-03-08 11:04:26 CET
Hi, when HUP is passed, with:

killall -HUP unbound

unbound 1.5.2 crashes:

unbound: [803:0] notice: Restart of unbound 1.5.2.
unbound: [803:0] error: user 'unbound' does not exist.
kernel: unbound[803]: segfault at 10 ip 0000000000458d85 sp 00007fff7a50eed0 error 4 in unbound[400000+a9000]


Whereas 1.5.1 works correctly:

unbound: [20260:0] notice: Restart of unbound 1.5.1.
unbound: [20260:0] notice: init module 0: validator
unbound: [20260:0] notice: init module 1: iterator
unbound: [20260:0] info: start of service (unbound 1.5.1).

The user and group "unbound" are present, and correctly used by unbound 1.5.1
Comment 1 Wouter Wijngaards 2015-03-09 09:07:46 CET
Hi Paul,

This bug is fixed in 1.5.3.  You can download 1.5.3rc1 straight away from here:
http://www.unbound.net/downloads/unbound-1.5.3rc1.tar.gz
Or wait for the release (which is imminent).

Best regards, Wouter

*** This bug has been marked as a duplicate of bug 647 ***