Bug 577 - Makefile incorrectly installs man pages from $(srcdir)
Makefile incorrectly installs man pages from $(srcdir)
Status: RESOLVED FIXED
Product: NSD
Classification: Unclassified
Component: NSD Code
4.0.x
All Linux
: P5 normal
Assigned To: NSD team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-07 00:03 CEST by El Grotto
Modified: 2014-05-07 08:37 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description El Grotto 2014-05-07 00:03:38 CEST
In the Makefile for "make install", the man pages are installed from $(srcdir). However, when using a separate build directory the man pages are built in the build directory. Therefore "make install" fails to work unless building in the source directory.

To reproduce (if it isn't obvious):

1. Untar the NSD source: tar xf nsd-4.0.3.tar.gz
2. Create a build directory alongside the source: mkdir nsd-build && cd nsd-build
3. Configure: ../nsd-4.0.3/configure
4. Build: make
5. Attempt install: make install

Step 5 will fail with the following error:

install: ../nsd-4.0.3/nsd.8 does not exist

(because it exists in the current [build] directory).
Comment 1 Wouter Wijngaards 2014-05-07 08:37:49 CEST
Hi El Grotto,

Fixed.  Thanks for the debug and report!

Best regards, Wouter