Bug 478 - Fix nsd build with gcc 2.95
Fix nsd build with gcc 2.95
Status: RESOLVED FIXED
Product: NSD
Classification: Unclassified
Component: NSD Code
other
All All
: P5 normal
Assigned To: NSD team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 08:24 CET by Brad Smith
Modified: 2012-11-02 14:06 CET (History)
1 user (show)

See Also:


Attachments
nsd fix for gcc 2.95 (1.96 KB, patch)
2012-11-02 08:24 CET, Brad Smith
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Smith 2012-11-02 08:24:00 CET
Created attachment 215 [details]
nsd fix for gcc 2.95

The attached patch for trunk fixes the build with gcc 2.95. This also pertains to the 3.2 branch as well. Also in the diff I included an autoconf patch to make use of the compiler warning flag -Wdeclaration-after-statement to warn against such code in the future.
Comment 1 Wouter Wijngaards 2012-11-02 14:06:12 CET
Hi Brad,

Thank you for the patch!  I have used it on NSD3 and NSD4.

Best regards,
   Wouter