Bug 314 - Right Hand Side of NSEC records stored correctly after zone transfer.
Right Hand Side of NSEC records stored correctly after zone transfer.
Status: RESOLVED FIXED
Product: NSD
Classification: Unclassified
Component: NSD Code
other
Other All
: P2 normal
Assigned To: NSD team
: 315 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 14:24 CEST by Olaf Kolkman
Modified: 2010-07-19 11:52 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Kolkman 2010-07-15 14:24:56 CEST

    
Comment 1 Olaf Kolkman 2010-07-15 14:27:28 CEST
After zone transfer of a zone that oritinally contains:
 _bla._tcp.secret-wg.org.                        600     NSEC    HP\032Deskjet\032D4200\032series._ipp._tcp.secret-wg.org. CNAME RRSIG NSEC


The zone is written to file without the spaces escaped to \032

When the domain name is the owner name of an RR the spaces are properly escaped.

--Olaf
Comment 2 Olaf Kolkman 2010-07-15 14:28:14 CEST
*** Bug 315 has been marked as a duplicate of this bug. ***
Comment 3 Matthijs Mekking 2010-07-19 11:52:21 CEST
Fixed in trunk, also fixes label overflow issue.