Bug 201 - NULL pointer dereferencement in unbound
NULL pointer dereferencement in unbound
Status: RESOLVED FIXED
Product: unbound
Classification: Unclassified
Component: server
unspecified
All OpenBSD
: P2 normal
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 12:01 CEST by Frank DENIS
Modified: 2008-08-04 14:16 CEST (History)
2 users (show)

See Also:


Attachments
GDB backtrace (3.15 KB, text/plain)
2008-08-03 12:01 CEST, Frank DENIS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank DENIS 2008-08-03 12:01:20 CEST
Created attachment 76 [details]
GDB backtrace

Hello,

The unbound-host tool randomly crashes with a NULL pointer deref.

Tested with Unbound 1.0.1 on OpenBSD/i386 and OpenBSD/amd64 (OpenBSD-current).

Here a trivial way to reproduce this. Try the command several times until it crashes:

$  unbound-host 213.154.224.1
[1]    9271 segmentation fault (core dumped)  unbound-host 213.154.224.1

Backtrace attached.
Comment 1 Wouter Wijngaards 2008-08-04 10:44:06 CEST
I can reproduce this.
Comment 2 Wouter Wijngaards 2008-08-04 14:16:46 CEST
Fix is in subversion trunk. The problem was that udp queries were still waiting for a random port when the application quits. Fixed to handle that correctly.

Thank you for the bugreport and trace,
   Wouter