Bug 138 - NSD fails if ip6 not supported on a machine
NSD fails if ip6 not supported on a machine
Status: RESOLVED FIXED
Product: NSD
Classification: Unclassified
Component: NSD Code
2.3.x
All Linux
: P2 minor
Assigned To: NSD team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 16:34 CEST by Wouter Wijngaards
Modified: 2006-08-15 16:35 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wouter Wijngaards 2006-08-15 16:34:47 CEST
NSD fails to bind 'all interfaces' if IP6 is compiled, but not supported on the machine. Instead of abort, fallback to IP4.

If the interface was given explicitly, or via -ip6-only option, then abort with error.

See workaround for this bug in fedora core init scripts. Submitted by Paul Wouters.