Bug 1302 - [ecs] cache hit/misses stats for ECS
[ecs] cache hit/misses stats for ECS
Status: RESOLVED DUPLICATE of bug 4146
Product: unbound
Classification: Unclassified
Component: server
1.6.2
Other All
: P5 enhancement
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-17 05:32 CEST by Manu Bretelle
Modified: 2018-09-04 18:27 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manu Bretelle 2017-06-17 05:32:45 CEST
Currently, with ECS enabled, all queries are showing as cache misses. It would be useful to get a better understanding of the ECS cache hitrate.

I started looking into the code, but I am kind of at lost as to were exactly cache hits/misses should be accounted for.
Comment 1 Manu Bretelle 2017-08-02 17:23:07 CEST
Hi,

Checking back on this. Being able to track ECS cache hit would be useful to understand cache efficiency.

Thanks
Comment 2 Manu Bretelle 2018-09-04 18:27:45 CEST
I realized this had been implemented and made it in 1.8.0 rc1 as part of #4146
Comment 3 Manu Bretelle 2018-09-04 18:27:54 CEST

*** This bug has been marked as a duplicate of bug 4146 ***