Bug 1178 - Unbound 1.6.0rc1 - Setup Error
Unbound 1.6.0rc1 - Setup Error
Status: ASSIGNED
Product: unbound
Classification: Unclassified
Component: server
unspecified
x86_64 Windows
: P5 normal
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-10 02:08 CET by drahnier
Modified: 2017-02-10 04:04 CET (History)
2 users (show)

See Also:


Attachments
Unbound 1.6.0rc1 Setup Error (349.71 KB, image/png)
2016-12-10 02:08 CET, drahnier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drahnier 2016-12-10 02:08:43 CET
Created attachment 366 [details]
Unbound 1.6.0rc1 Setup Error

Possibly minor, but here it is anyhow:

At the end of installation on a Windows 10 system Unbound Setup throws an application error (see attachment). Unbound seems to have installed correctly despite of this error and - so far - is working nicely.
Comment 1 Wouter Wijngaards 2016-12-14 10:06:46 CET
Hi Drahnier,

This seems to be an error in the NSIS generated code.  I have changed it to pop result values off the stack there.  I hope it makes a difference, but otherwise there is nothing there I can change, I think.

Here is a link to a version with that pop.
http://www.nlnetlabs.nl/~wouter/unbound_setup_1.6.0rc78.exe

Best regards, Wouter
Comment 2 drahnier 2016-12-16 03:10:45 CET
Appears to be fixed, since this no longer happens when installing the Unbound 1.6.0 release version.
Comment 3 drahnier 2017-02-10 04:04:26 CET
This supposedly fixed setup error is back in 1.6.1rc1.