Bug 1176 - Segmentation fault on Alpine Linux 3.4
Segmentation fault on Alpine Linux 3.4
Status: RESOLVED FIXED
Product: unbound
Classification: Unclassified
Component: server
1.5.10
x86_64 Linux
: P5 major
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-09 11:00 CET by Uladzimir Trehubenka
Modified: 2016-12-09 11:10 CET (History)
2 users (show)

See Also:


Attachments
Docker build env for reproduce the issue. Also included quick fix. (2.09 KB, application/zip)
2016-12-09 11:00 CET, Uladzimir Trehubenka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uladzimir Trehubenka 2016-12-09 11:00:22 CET
Created attachment 365 [details]
Docker build env for reproduce the issue. Also included quick fix.

On Alpine Linux default thread stack size is 80 Kb. See
http://wiki.musl-libc.org/wiki/Functional_differences_from_glibc#Thread_stack_size
This is not enough for Unbound and cause segmentation fault. Other linux distros have 2 Mb at least. NOTE: num-threads should be more than 1.
Comment 1 Wouter Wijngaards 2016-12-09 11:10:24 CET
Hi Uladzimir,

Thank you for the detailed report.  The patch looks good, I changed the logging and included it as-is.  Since the rc1 for 1.6.0 is already out, this one has to wait for 1.6.1 (because of the pthread usage and portability) for release.

Best regards, Wouter